読者です 読者をやめる 読者になる 読者になる

purazumakoiの[はてなブログ]

技術メモから最近はライフログも増えてきてます。

CentOS 5.5 32bit にzabbix 2.4 インストール

参照
Zabbix 2.4 を yumでインストール(CentOS6.5) | あぱーブログ

サーバ環境

CentOS 5.5 32bit
Apache 2.2.3
PHP 5.2.16
Mysql 5.1.52

インストール設定

#zabbixのyumリポジトリの登録
rpm -ivh http://repo.zabbix.com/zabbix/2.4/rhel/5/i386/zabbix-2.4.2-1.el5.i386.rpm

yum -y --nogpgcheck install OpenIPMI ipa-pgothic-fonts fping iksemel libssh2 lm_sensors net-snmp unixODBC net-snmp-libs
yum -y --nogpgcheck install zabbix
yum -y --nogpgcheck install zabbix-server 
yum -y --nogpgcheck install zabbix-web 
yum -y --nogpgcheck install zabbix-server-mysql 
yum -y --nogpgcheck install zabbix-web-mysql 
yum -y --nogpgcheck install zabbix-web-japanese
yum -y --nogpgcheck install zabbix-agent
yum -y --nogpgcheck install zabbix-get


# yumリストチェック
yum list | grep zabbix


つまづいたところ

32bitマシンなのでこのエラーが一回でました。うっかりです。

エラー: 依存性の欠如:
        rpmlib(FileDigests) <= 4.6.0-1 は zabbix-release-2.4-1.el6.noarch に必要とされています
        rpmlib(PayloadIsXz) <= 5.2-1 は zabbix-release-2.4-1.el6.noarch に必要とされています

参照:http://blog.bungu-do.jp/archives/4185

Public keyのエラー

Public key for zabbix-server-mysql-2.4.2-1.el5.i386.rpm is not installed

これを回避するために--nogpgcheckオプションをつけた

zabbix-web-pgsqlとzabbix-web-mysql共存できないので、片方をyum removeする

Error: zabbix-web-pgsql conflicts with zabbix-web-mysql
Error: zabbix-web-mysql conflicts with zabbix-web-pgsql

pgsqlかmysqlの片方をyum removeする